American Truck Simulator not detected after fresh Overwolf installation

Related app/team name (not a must if you want to keep it private): Trucky
Issue Description:

After a fresh Overwolf installation, uninstall and reinstall, American Truck Simulator is not detected as installed or the app is not linked to it.

I’ve my app loaded as unpacked.

If i launch the game, via Steam or via my app, the overlay is injected correctly, the GEP is working but hotkeys are not working.

The Settings screen appear as follow:

ETS2 is working.

Can you reproduce it (exact steps to reproduce):

  • Have ATS installed
  • Uninstall Overwolf
  • Install Overwolf
  • Launch the game

Impact for my app: [e.g. x% of the users complained about it, it’s a show-stopper]: by now only me
Do you currently have a workaround?

Please reproduce and attach a zip package of your OW client logs

Just happened (197.3 KB)

Hi, and thanks for the feedback.

We will check the issue and we will update you here.


hi eran,
any update on this?

This issue is escalating quickly.

Many users, every day, is reporting this. They are fixing with reinstalling ATS aftet the Overwolf installation.

No response for 12 days for a supported game not detected and overlay not working with an installed base so big is… worrying.

Updating here is that we continued the discussion on Slack. I will update here later as well.

Hey, @dowmeister.

let’s back to here…

So we did a few more tests, and these are the results:
When a game (any game, not just ATS) is running in the background, and you are installing OW - the overlay will not work until the game is restarted.

I checked the above scenario with Trucky and ATS, and it’s working as expected: while the ATS is running, I installed OW. The overlay didn’t work.

I uninstalled OW, closed the game, and then installed OW. After we finished the installation, I ran the game. This time, the Trucky auto launched when I started to drive. As expected.

I checked both of the scenarios multiple times.
Can you please tell me if I’m missing something here?

@eransharv no, the game wasn’t running. It’s clear if the game is not running, it couldnt work.

Don’t know why you focused on game state… i didnt mentioned the game was running.

If you can’t reproduce, it’s ok. You can close this but it’s still absurd that ATS works differently from ETS2 on Overwolf.

@dowmeister, I forward it to our QA team to recheck it to find any differences between ATS and ETS. I will let you know ASAP.


I am updating that the QA team will be available for that just at the begging of the following week.

Thanks for your patience.

Any news about this?

Hey @dowmeister,

The QA team and I rechecked it today - with a fresh installation of ATS, then a new OW public latest version (OW client bundled with Trucky), everything worked as expected. I mean overlay and hotkeys.

We also did the same check-in ETS. Same results.

Would you mind rechecking it on some other machine? If you can reproduce it consistently, please send me the exact steps. We can do a screen share session if needed. But currently, I don’t have any other actions available from my side.

Please let me know if you have any other suggestion.



I’m closing the issue. If it’s still relevant, just mention me here, and I’ll reopen it.