Apex - Ranked Arenas are killing the GEP (wont recover after OW restart)

the new ranked arenas are NOT working - which is expected as it is new,
but once you play a ranked arena game - the next time you play anything else the GEP gets angry and won’t trigger any more events (of any kind) except some damage events (total damage will keep counting from previous games to make you feel like a pro)

reregistering will not work (as in - app restart)
restarting OW did not work (multiple restarts tested)
restarting the game (while OW is still running in “no events” state) WILL fix this.

this also caused a rogue match_start to pop up in the lobby screen out of nowhere… so ya :slight_smile: evil bug.

logs attached, “GAMEMODE_ARENAS_RANKED” will mark the timelines :slight_smile:

OverwolfLogs_2021-08-08_05-13-23.zip (3.5 MB)

Hey boaz, thanks for the report.

Ranked arenas are new as you mentioned and we are still looking into its support.
We’ll update you as soon as we get a fix.

So just to clarify, we performed some internal testing and it doesn’t look at all like events stop working.
I’ve made several attempts at arena ranked and straight into battle royale afterwards and the events were working well for me.

We’ll continue to investigate if there’s anything that can be done.

I’d like for you to tell me whether this scenario is reproduced for you 100% of the time

Just tried again…
first try was ranked arena → br - was ok. (so already not a 100% chance, BUT this is the ONLY time it didn’t crash on me)
the second try was ranked arena → arena (already not working) → br (still not working), restart OW → still not working

Apps\Overwolf General GameEvents Provider\index.html.2105.log
line 3879 - is where i switch to arenas (after playing ranked arenas) that’s the point of no return.

OverwolfLogs_2021-08-08_21-37-18.zip (3.2 MB)

if you need me to run some debug-enabled binaries to help out - my computer is your computer.

We begun phasing out a fix for ranked arena, it should fix the issues you are experiencing.

The version is 177.1.4, wait a few hours until you get it and let me know if the issue still occurs.

1 Like

I’m closing the ticket as it should be fixed. If not - please mention me, and I’ll reopen it.