Desktop window not showing up in taskbar until user clicks on it

I am having the following issue, which was also shared on Slack by Frederick Lee (description is copied from their original Slack post):

Does anyone have an issue with desktop windows not showing up in the taskbar when an app is launched while Overwolf is in “game mode”?

The window still shows up on the monitor, but the desktop window only shows up in the taskbar when it is either clicked or alt-tabbed to.

I’m calling it “game mode” and “desktop mode” because launching the OW Appstore while Hearthstone is open results in a message popping up saying, “Overwolf Appstore can only be opened on desktop.”

This is especially noticeable in Hearthstone where OW will stay in “game mode” even if I click outside of the game window or alt-tab to something else. OW only returns to “desktop mode” when I either minimize Hearthstone or launch the app from another shortcut outside of the game (desktop link or start menu link).

Other games, like CS GO, return OW to “desktop mode” when ever I click or alt-tab out of the game. However, if I launch the app from within the game (OW dock inside the game or dev packages window while it is captured by the game window) and the game window remains focused (for CS GO only. I can click else where for Hearthstone), then I run into the issue where the desktop window doesn’t show up in the taskbar.

I have been experiencing the same issue for a long time (actually as far as I can remember).

1 Like

Hi, and thanks for the feedback.

We will check the issue and we will update you here.

Thanks.

Can you please write the exact steps to reproduce? i want to make sure that I’m reproducing it correctly. As currently, I was not able to reproduce.

What I’m doing (setup is Firestone + double screen, don’t know if it also happens in single screen setups):

  • Go to the Settings inside Firestone, then Battlegrounds, then make sure “integrated mode” is turned off
  • Start a Battlegrounds game
  • A window will appear on your second monitor. In my case, that window doesn’t have a taskbar icon until I click on it or alt-tab to it

@sebastientromp we were able to reproduce it. I will create a bug and update you when it is fixed. Thanks.

2 Likes

+1
interested to hear about the fix :slight_smile:

+1
interested to hear when fixed as well!

We are already working on a fix. We will update here.

Thanks.

1 Like

@sebastientromp We released a possible fix for this issue on 168 (Developers channel), can you please check if this bug is still reproducible?

So far it’s looking good. I will update here if the issue still reoccurs.

1 Like

fixed also for me on 168

1 Like