Error loading C# Plugin (The extension does not include extra objects)


I’m having a sporadic issue with loading a plugin DLL.

I have detected an issue where the plugin will not load properly, when consulting the console in the browser.

Step by step:

  • I try to load the plugin using overwolf.extensions.current.getExtraObject.
  • When checking if the plugin was successfully read, it show this error:

Lines of code that produce that error:

My manifest file looks like this:

"extra-objects": {
    "RoundByRoundPlugin": {
      "file": "files/plugins/RoundByRound.Plugin.dll",
      "class": "RoundByRound.Plugin.RoundPlugin"


Things that I’ve tried:

  • Using .Net Framework 4.5 and 4.8 to compile the DLL
  • Both x86 and x64 versions of the DLL in both of the frameworks

I’ve uploaded the code to github if you want to have a closer look at the code.
I’ve also tried to put this code in the background.ts so it tries to fetch the DLL without the need of running the game.

Any help will be greatly appreciated.

Hi, this might be due to your plugin’s class method signatures - try to start with a simple method that has no return values (void).

Check out our sample plugins on github: GitHub - overwolf/overwolf-plugins: A solution with a bunch of Overwolf plugin dlls

1 Like

Thanks Tom!

Although that might be one of the reasons why, I was using async Task, instead of void, it still produces the same error.

The new signature looks like this:

I’ve updated the github with this code aswell.
It produces the same error as before:

Also notice that something might not be right with your sample code

You have a different namespace in the code and in the manifest, is that right ?

In your manifest, make sure to place “extra-objects” under the “data” property.


It was that, thanks tom it’s working properly now.