Game volume audio setting is not applying properly to recording

Related app/team name (not a must if you want to keep it private):
Insights Capture, but confirmed the same issue affects Outplayed as well.

Issue Description:

  1. When the filtered_capture audio setting is enabled, the stream will always record the game at full volume.

I.e. I change the game volume to some else other than 100, but the resulting recorded video still sounds as loud as if the video is recorded at 100% volume.

I tried recording with the below settings. The volume was set to 0, but it was still as loud as a recording with volume at 100.

"{
  "provider": "VideoRecorder",
  "settings": {
    "audio": {
      "game": {
        "volume": 0,
        "enable": true,
        "device_id": "{0.0.0.00000000}.{4281b1de-72f0-4da6-9058-55f0de3e9074}",
        "filtered_capture": {
          "enable": true,
          "additional_process_names": []
        }
      },
      "mic": {
        "volume": 100,
        "enable": false,
        "device_id": "{0.0.1.00000000}.{33fea8a4-9489-44a0-85f7-f8f788c4d935}"
      }
    },
    "video": {
      ... // video settings omitted
  }
}"

The OBS logs is also showing the correct volume passed into the streaming.start call.

  1. When filtered_capture is not enabled, the recorded video is very quiet.

I have Window’s volume setting at 5 while recording a game, but when playing back the video in Insights Capture, Outplayed, or a third party dedicated video player, I have to turn Window’s volume up to 50 - 60 to hear the video. The game audio recording setting passed into stream.start is 100.

Setting the volume below 100 in the case makes it even quieter.


Can you reproduce it (exact steps to reproduce):
Can reproduce using Insights Capture or Outplayed. It’s convenient to use Osu! because the menu screen has music playing.

Record with filtered_capture enabled to see situation 1 above. The video is always recorded at max volume regardless of volume setting passed in.

Record with filtered_capture disabled to see situation 2 above. The resulting video is much quieter than the game.


Impact for my app:
A user is saying IC is recording videos very loudly while other apps are not. They have filtered_capture enabled, so they are running into situation 1. I’m guessing they have filtered_capture disabled when trying other apps.


Do you currently have a workaround?
No.

Please reproduce and attach a zip package of your OW client logs
stream audio volume not working properly OverwolfLogs_2023-01-19_17-20-26.zip (2.1 MB)

ow_obs_2023-01-19_16-59-48-p13544.txt
Recording with IC.
Volume at 0, filtered_capture enabled. Video has sound at max volume.

ow_obs_2023-01-19_16-40-37-p22984.txt
Recording with Outplayed.
Volume at 52, filtered_capture enabled. Video has sound at max volume.

Hi!
Thank you for the detailed report, we will take a look and keep you updated.

We have managed to reproduce this behavior, and are looking into a fix.