Mouse cursor disappearing for some users

Some users reported that their mouse cursor was disappearing while in-game when they had my app running. It’s been reported often enough that I think it’s a real issue, but I have no logs nor screenshots (users who reported the issue didn’t leave any contact info).

Is this an issue you’re aware of? Do you have any idea what could be causing this?

Did you set a focus_game_takeover flag?
Are you playing maybe with onMouseUp event or something similar?

I really can’t think about something else. Please try to reproduce and let me know if succeeded. I need some exact steps to reproduce.

Did you set a focus_game_takeover flag?

None of my windows have this flag set

Are you playing maybe with onMouseUp event or something similar?

I do have some mouse listeners set up, but none that should interact in that way (I use them to trigger events).

I really can’t think about something else. Please try to reproduce and let me know if succeeded. I need some exact steps to reproduce.

Got it, thanks. As mentioned it happens only to a small number of users, and I can’t reproduce it myself. I’ll keep an eye open in case I face it again

1 Like

CUrrently i will close this ticket. But feel free to re-open it (by mention me) as needed.

@eransharv it has happened to me right now as well. The full logs are there: (2.0 MB)

What I though I did was to move the game window while it was in windowed mode and maximized, but I can’t reproduce it now

@sebastientromp sorry I closed the ticket by mistake.
I will take a look on that ASAP.


update: I tried again to reproduce it without success.

@sebastientromp, to be honest, I’m not sure if to close the issue or not.
I can’t reproduce it and can’t find it.

Are the users still complain about it? Are you able to reproduce it?
If you want, you can reproduce it another time, we the latest version (0.153), add (again) the logs. And the exact steps to reproduce. And I’ll escalate it to our R&D.

I just received a report today:

mouse cursor disappears when hearthstone window is resized or moved maybe

But I can’t reproduce it myself

And I just got a similar report today

Any resizing of the screen causes my cursor to disappear.

Another one

Ive recently been experiencing an issue where my cursor disappears, but only when hovering over Hearthstone. It also reappears when im hovering over any Firestone overlay so i was very confused. Im not exactly sure what causes this to happen but it seems that its whenever im resizing my windows. I can still click on things in the app but it is very difficult to play. Restarting Hearthstone along with Firestone fixes the problem.

@sebastientromp we couldn’t reproduce this issue either, but our support team is in contact with a user that can reproduce this. We’ll try fixing this issue and will update you once it’s done.

Reports on HearthArena too:

I’ve experienced this myself troughout recent years every now and then but thought it was dev-env related.

We are checking it and we will update you here. Thanks for your patience.

@LEOkonami FYI.

@heartharena Hi,

So we tried to reproduce the issue with the QA team, and we failed.
As far as I can see it we have two options here:

  1. Close this ticket and keep an eye on it until there are further details.
  2. Find a user that it’s reproducible - and connect between him and our Support team to more advanced debug sessions like debug plugin or even remote screen share.

What do you think? I think that at this point, option 1. sounds more reasonable. As I guess that currently, we can’t find our “golden” user that has this problem all the time…

@eransharv As per itay’s comment, I thought you were already in contact with a user who has this issue. Has that changed?

I receive regular reports about users for whom the mouse cursor disappears, and it seems to mostly happen when they are resizing the game’s window.

So I would rather that the ticket remains open, as it is a very real issue that affects multiple users.

@sebastientromp, unfortunately, the user wasn’t responsive anymore.
I will leave this ticket open for now - and please update me with any new info or any way that you can find to reproduce it. We would be delighted to catch this sneaky bug too :slight_smile:


Thanks for the update.

In the future, don’t hesitate to keep me updated when this kind of things happen, as I can ask others who report the same bug if they are willing to help :slight_smile:

Update: I had a session with @sebastientromp that shared the screen with me and showed me the bug.
He DM the logs, and we will update here in the next few days.

Send some logs to @eransharv on slack.

Here is what happened:
Started Hearthstone.
HS is in windowed mode.
Did not play an actual game yet.
I think I did check the Overwolf dock during this step to open my app.
But eventually opened my Dev App from desktop shortcut.
My mouse cursor is gone when hovering over the game window (including the title bar).
The above could have already been the case before I started my app, not too sure.
When hovering over an in-game overwolf app window, I can see my cursor.
When hovering over the game itself I cannot see any cursor, but I can still interact with the game.
Hovering my pointer over the titlebar of the windowed Hearthstone, also hides the cursor.
Left-click dragging the titlebar will actually show a mouse cursor, but it will be gone once i stop dragging.
Changing resolutions or going to fullscreen mode doesn’t not fix the issue.
Restarting Hearthstone fixed it.

When it comes to Overwolf or my test App’s state, I am really not sure the order or state my app was in and if this caused the effect. I was casually opening Hearthstone and might have not noticed that my test app was already running in the bg.

1 Like