MtG Arena no longer recognized by OW

Issue Description: MtGA is no longer recognized by OW
Steps to reproduce:

  • open up the sample MtGA app and Arena in either order
  • Examine the console log
  • Expected Behavior: returns an object that is logged to the console
  • The argument for the callback to is null

Impact for my app: showstopper
Right now there is no good work around. No app with render as an overlay if OW doesn’t know that Arena is running.

You can use the sample app for MtGA which I have built and attached below for ease of use.
Magic the Gathering Arena Game Events Consumer Sample-0.0.1.opk (14.1 KB)

I’m checking this issue. I will update ASAP (later today).

Hi. I tested it using our MTG events sample app.
I do get the logs, when i’m getting to the home screen in a game:

At this point, you should get this line in the dev console log (of the MTG events sample app):

Info UPDATE: {"info":{"game_info":{"scene":"scene_home"}},"feature":"game_info"}

Also, it might be that you detailed log option is disabled in the game UI (under “account”):

Please re-check and let me know.


Hey! Thanks for checking this out. I have that setting checked and I am also getting the full detailed logs. But is still always giving me back null.

And yeah it is weird that I’m still getting those info updates. But for some reason I can’t tell that the game is running. As a side effect I am also unable to get Arena Tutor to display as an overlay despite the overlay being enabled in settings.

I can check that the overlay issue happens with the store version of AT as well or I can DM you a version of AT that has this issue.

I double-check it and once the game is loaded I do get a response from

{isInFocus: false, isRunning: true, allowsVideoCapture: true, title: "Magic the Gathering: Arena", displayName: "", …}

Please make sure that your OW client is up to date, your game up to date and your OW overlay settings are set correctly.

I am running on the web_dl_btn channel. I definitely have the overlay settings turned on.

Is there any other reason why that would be working for you but not for me?

Can you please recheck it with the public OW channel? (called “Website”)
Then, of course, restart OW and restart the game.

If it is still reproducible, please attach here your client logs.

I switched to the Website channel and I am still getting only null from (1.1 MB)

Forgot to come back and reply here again. I fixed this issue restarting my computer. Still no idea why this happened or how to duplicate this issue.

1 Like

ok keep an eye on that. and if it’s reproduced in the future, let us know. thanks.
closing this ticket.