[overwolf.media.replays] Cannot turn replays off and on again

After starting, overwolf.media.replays in game (calling overwolf.media.replays.turnOn), I’m attempting to restart the service.

Sometime, we are getting HELPER_DISCONNECTED from overwolf.media.replays.
we would like to restart it to get it back in working order

I’m performing the restart by calling overwolf.media.replays.turnOnff, awaintg that it will finish, and then call overwolf.media.replays.turnOn again.


overwolf.media.replays should be working properly and we should get highlights as usual


overwolf.media.replays acts as if everything works, but no highlight is saved

Impact: high

@shir.brass I’m not sure, but it looks that this error usually happens when you quit the game while playing. Is that is the case?

So your scenario is:

  1. You are calling overwolf.media.replays.turnOn to capture auto-highlights.

  2. After a while, while the game is still running, you start to get the HELPER_DISCONNECTED error (I guess that you registered to the OnStreamingStoped event), and the capture is stopped?
    What happened on this point, if you are trying to call turnOn without stop?

  3. then, you want to restart the capture, so you are doing turnOff and expect that after an additional turnOn, everything will work as expected? but it’s return success but no actual highlights are captured from this point.

Is the above right? can you please confirm it.

Anyway, please reproduce it and attach your client logs. Thanks

regarding the said scenario:

  1. correct
  2. I get the said error via overwolf.media.replays.onCaptureError, and the capture stops. assuming that I want to work cleanly, I tried turning off and on again, but I’ll try only turning on without stop.
  3. yes, that’s my expectation, and that’s exactly the way that it happens.
    (btw, if I turnOff highlights mid game without receiving an error, it will also do this behavior)

I’ll attach logs and reproduction as soon as I can

hey @shir.brass do you have the logs + steps for repro?

While trying to reproduce the issue I have found out the problem

I tried turning it off and on again too quickly (less then a second apart)

once I gave it more then a second, the API worked as expected.

I’m closing the issue

1 Like