Issue Description: Not able to turn on highlights

I am not able to turn on highlights ,initially it says “noEncoderset” on error description .
I have attached code and error description

“noEncoderset” error was gone after i managed to add an encoder “overwolf.streaming.enums.StreamEncoder.X264”. Now it shows no error description but shows “status” as error.

Note: Same method was doing perfect job before migrating to TS.



I hope code snippets are enough :slight_smile:

Hi, and thanks for the feedback.

We will check the issue and we will update you here.


Hi, and thanks for your patience.

First of all, from the OW client UI, go to settings=>capture=>advanced and check if you have a list of encoderes:


That’s to ensure no local issue on your machine, and the OW client can read your encoders.

After that, the right way is to use the default encoder that is picked automatically or to check which encoders are available on your machine. You can read all the details on how to do that on our guide here.

Hi, Thanks for writing back
Issue is resolved, app was missing “VideoCaptureSettings” from manifest file.
well, its shocking that prev app was able to capture highlights without these settings in manifest.

@qamaruddin Hi,

Why do you think that another app was able to capture without this permission in the app’s manifest?

That needs to be investigated,
Would highlights also work if manifest has permissions for “Streaming”? As i know prev app was having permissions for “Streaming” but it was able to capture highlights