overwolf.settings.getHotKey fails on Dev channel

just noticed mid-work that the old deprecated and loved overwolf.settings.getHotKey method went kaboom.
not sure if this is intentional to make it obsolete or a mistake…
tried switching back to the normal channel → works again, jumped back to dev → fails again.

returned error: “Hotkey for feature ‘HOTKEY_NAME’’ not found” (HOTKEY_NAME is just an example :slight_smile: )

please advise if doomsday is upon us or if it will be fixed by your side before being pushed to the normal channel :slight_smile:

note: console warning & docs still claim it to be deprecated and not obsolete.

Hey Boaz, I tried to reproduce this internally, but it worked well for me.
Could you please provide the exact reproduction steps you used and the app you used it on?

No doomsday is upon us so far, if this is indeed a bug, we’ll fix it before this version goes love.
Worry not brave friend.

Heya, can’t reproduce it ever since I reported. can’t really explain why…
When it happened I tested it with multiple apps and restarted OW quite a lot of times (due to the channel swapping) and the behavior seemed very straightforward.
also failed on production versions from the store \ dev versions \ direct call from the dev console terminal.

but now it works like a charm :open_mouth:
i mark it as voodoo, will update if anything changes.