overwolf.utils.openStore fails to open the app listing at the first opening

Related app/team name: Fuze
Issue Description:
(Starting the app from a desktop icon).
When opening the store from an app, while the store is closed some bugs occur:
a. AppStore opens without opening the subscriptions modal or without the app listing at all.
b. Window focus jumps between the originating app window to the store window, it is a very buggy look-n-feel.

Code used in the app:
overwolf.utils.openStore({
page: overwolf.utils.enums.eStorePage.SubscriptionPage
})

Can you reproduce it:
Yes:

  1. Fully Close OW.
  2. Start the app with a desktop icon.
  3. Click on the subscribe button.

(Tried to repro with other apps which implements subscriptions - the behaviour is exactly the same).

Impact for my app:
We are about to launch a subscription model, and this behaviour isn’t smooth enough.

Do you currently have a workaround?
No

Attached link to a shared folder with:

  1. app listing opens only on the second attempt.mkv:
    case a: video shows the behaviour of appstore opened without the specific app listing.

  2. blinking appstore.mkv
    case b: window focus jumps.

  3. Logs of blinking at local time 2021_03_24__16_06.zip

https://drive.google.com/drive/folders/1kE_ZRJMzvLj7yAWlcGlfrMIyZMY7Ue7b?usp=sharing

We are looking into it

1 Like

@Genizzz Hi,

We are unable to reproduce the issue.

Can you please re-check it with the latest OW client version from the Developers channel?
If you can reproduce, please tell us the exact steps (if they are different from the actions you described in the original post).

Thanks.

Issue A reproduces on OW v0.169.0.11.
Just in case - here’s another video of the case: issue shown on lolwiz 2021-04-05 18-35-14 ow 0.169.0.11.mkv - Google Drive
You can see the first navigation takes me in the AppStore, without the specific-app context and without opening the subscription modal.

Issue B was also reproduced. Not from the first time, not always. Not sure about the exact steps, got a video of my steps. There’s something with the focus jumping between the windows.
Also on OW v0.169.0.11
Here another link:
Latest video + Logs folder.
https://drive.google.com/drive/folders/1ZnFJKH4Dz9CIdezR0fc41IQbpzj09toB?usp=sharing

@Genizzz hi,

I’m on Developers channel v0.169.

Issue A

Link to the video.

I was still not able to reproduce the issue. Steps that I did:

  1. Reinstall lolwiz. (remove + install)
  2. Open the app from the desktop icon.
  3. on the desktop window, hit the “subscribe” header button.
    Expected: Get to the app’s subscription page in the store (the “sprite” page)
    Actual: same (not like you: you get to the store’s main page and that is not good).

I will continue to check it.

Issue B

link to the video.

I tried to reproduce it, but as I can’t see Ads on the desktop app’s page - I can’t test it. Do you know why I can’t see the ad with the link to the subscription page? Anyway, I will try to check why tomorrow.

As of issue A, please try to add a step between 1 and 2 - Exit Overwolf.

(In the test scenario it is just exiting Overwolf, in a real-world scenario - machine restart may occur).


Issue B - I’ll try to reproduce tomorrow with another app, as we are not stable for production yet. Do you think it is related to Ads somehow?

@Genizzz regarding issue A , do you mean that we should restart OW or just exit?? (if OW is closed than the appstore can’t be opened ofc)

Regarding issue1. I added your step - exit Overwolf and ran the app from the desktop. But still - I get the correct app’s store sprite. Did you check it on other machines?

@itayG I was referring to OW Exit (from tray), yet while opening an app from the desktop OW would be opened automatically…

@eransharv checked now with another machine of Developers channel - works as expected. :thinking:
Do you have any guess why it is not working on my machine?

Maybe some local cache issues.