[Reddit Share] outplayed.tv doesn't contain event name in pretty url and video title

When a video is shared to reddit using overwolf.social.reddit.share, the provided event name does not appear in the title on Outplayed.tv.

Here’s a sample of Reddit share result on Outplayed.tv:
Highlight #League of Legends | Captured by #Outplayed

Here’s a sample of Discord share result on Outplayed.tv for the same video:
PvP Round #League of Legends | Captured by #Outplayed

I’ve seen in Reddit docs that reddit should work with tags and not events, but when I sent the tags field, the reddit url was broken: https://www.reddit.com/invalid_token?url=https%3A%2F%2Foutplayed.tv%2Fmedia%2FDL7Gr%2Flol-pvp%2Bround&token=AQAA9w85X0ipVqZoDc6DD3LdlYaEJjUx-E48ishSmtIAevp3MsGd&app_name=desktop2x&user_id=471447993012

Steps to reproduce:

  1. send reddit.share call with the following parameters"
  "file": "file://D:\\Videos\\Overwolf\\Outplayed\\League of Legends/League of Legends_8-16-2020_2-6-20-576\\League of Legends 08-16-2020_2-06-22-522.mp4",
  "events": [
    "PvP Round"
  "gameClassId": 5426,
  "gameTitle": "League of Legends",
  "title": "Check out my video! #TeamfightTactics | Captured by #Outplayed",
  "subreddit": "clips",
  "trimming": {
    "startTime": 1136507,
    "endTime": 1177391
  "metadata": {
    "mode": "tft"

Impact for my app: [low, mid, high, show-stopper]
Do you currently have a workaround?

Please reproduce and attach a zip package of your OW client logs
Please mention the time of the event so we can find it easily in the logs

@shir.brass I want to clarify: is the Reddit share() is working with the events instead of the tags param - or it’s not working at all?

@eransharv it’s already working with events instead of tags, except that tiny issue that we’ve found in outplayed.tv (which is not under our control)

@shir.brass I guess that the root cause is a documentation typo. I fixed it.
I am closing the issue.


The problem still persists…

here’s a reddit post I’ve uploaded: https://www.reddit.com/r/clips/comments/if1joa/i_love_yone_check_out_my_video_leagueoflegends/

it includes this link to outplayed.tv: https://outplayed.tv/media/wyvx7/lol-yone (no event is added to the url’s end & to the video name

using the same parameters as before I tried sharing to discord and got this result:
https://outplayed.tv/media/b4vYZ/lol-yone-kill (as you can see, including the kill in the end of the url & the title includes kill)

Ok. so let me make sure that I understand the current status:
Anyway, there was a typo in the docs, and now it’s working with the events param (instead of tags).
Also, it not resolved the main issue - which is that the data from the events, is still dropped - and the clips are uploaded without a title.

Please confirm.

@eransharv yap, correct :+1:

OK. I will have to check that and maybe escalate it to the R&D.
What is the importance/urgency of this issue?

somewhere between low and medium
it’s an inconsistency between the various share APIs that we’d like to tackle.
but, a user has complained about the issue, which is why we think it’s higher then low (therefore leaning towards medium)

@eransharv do you have any update?

There is an open bug on it. It’s scheduled for OW client 0.157. So I guess it will be out pretty soon…
I will DM you the link to the bug.

1 Like

hey again :slight_smile:
OW client 0.157 was released quite some time ago
was it included in the version?

@shir.brass Unfortunately, it’s rescheduled to 0.163. which is the next version…
I will update you as soon as it’s live (and of course, you can track our announcement on the slack “announcement” channel.


1 Like

hey again :slight_smile:
as it appears, there’s no OW client 0.163 and the next version is 0.165.
I didn’t see anything regarding this isssue in the changelog
any update on the ETA?

@shir.brass I checked and there is an open bug that Gildon should fix in 0.166. This version should be released in 1-2 weeks.

1 Like

we’ve tested it in 0.166 and it still doesn’t work.
any new ETA on the issue?

@shir.brass I see that the R&D rescheduled it again to 0.167… let me check what is going on.

1 Like

@shir.brass Hi,

Reddit API is disabled now (login bug); let’s test again after a fix will be available (168).

1 Like

in This ticket, You said that reddit is availalbe again
Is this ticket resolved as well?

No. As far As I can see, the bug is scheduled for 0.170 (Assigned to Gildon).
They are starting to work on this version this week.

1 Like