Restoring a window while ingame sometimes minimizes the game

Related app/team name (not a must if you want to keep it private): Porofessor

Issue Description:
Restoring a window while ingame sometimes minimizes the game

Can you reproduce it (exact steps to reproduce):
This is a weird issue. For this one you need to have two screens.
A user send me an email today complaining that pressing ctrl+shift+x in my app would minimize the game, 10% of the time.
I then checkd on my pc, and even the initial ctrl+x would minimize the game. It of course didn’t do it in the past few days. And indeed, pressing ctrl+shift+x would minimize the game for me.
I tried to narrow down the issue using git bisect, but I couldn’t find a commit where this didn’t happen. Even commits from 6 months ago did trigger the issue. Which is really weird as I never had it and now it systematically happen.
Then I restarted the lol client and for some reason it never happened again.
Then I restarted the lol client and it happened again.
I tried disabling everything which could someone grab the focus (bringToFront for instance), and still got the issue. So atm, I’m thinking that it’s the .restore() method which is causing the issue, when restoring a window on another screen than the game one.
Then I rebooted my pc, no change
Then I uninstalled latest Window updates (KB5000802 & KB4601554) which were installed 2 days ago on my pc and rebooted. The issue doesn’t happen anymore, despite multiple tries to repro the issue

Here are the logs from the first user and a video of the issue (131.1 KB)

A second user complained and said

I have the desktop app, and recently it has caused some issues with fullscreen League. If I hit control-x to open porofessor, it forces the game to alt-tab, and then when I go back to league, it doesn’t enter fullscreen mode completely and causes horrible visual issues. I have to change the settings from windowed back to fullscreen in order to restore proper visual settings in league
This only occurs when porofessor is running
I’ve unisntalled and reinstalled both league and porofessor and there seems to be no improvements

I’ll continue to try to narrow down the issue, but atm I’m quite stuck

Impact for my app: Pretty high, as multiple users complained today. Not sure how far spread this is.

EDIT: reinstalled those windows updates, i don’t have the issue anymore.
So I’ve no clue where the issue is coming from.

Hi, and thanks for the feedback.

We will check the issue and we will update you here.


@trebonius0 Hi, we continue to reproduce and find the root cause of the issue, but meanwhile, if you can, we released a new version to the dev channel - v0.168. If you can also try to reproduce it there, that will be great.

Atm I cannot reproduce the issue with 0.168 :slight_smile:

@trebonius0 great! thanks.
@uzi FYI.