Subfolder is not getting applied

Here is the setting. Captured videos are not getting created under this subfolder. May I know, What needs to do?

The sub_folder_name Defines Subfolder for video file path destination:


So it would be best if you mentioned (not mandatory) the folder name.
And gives you the default videos folder of the current OS user, not the videos that the user set in the OW client.

I would like to set another folder called Captured inside the default videos folder of the current user. Videos need to be inside of it. But it didnt work.
Even I have used following setting as well. This is also not working.
“video”: {
“sub_folder_name”: ‘Test’,
“buffer_length”: 3000,
“override_overwolf_setting” : false,
“fps” :30,
“width” :1920,
“height” : 1080

Can you please provide me the working solution to set the folder.?

Any update on this.?

Please provide any update on this?


As I mentioned, the sub_folder_name Defines Subfolder under your default OW videos folder (as defined through the client UI).

So this line:


should be replaced with this line:

"sub_folder_name": "Captured".

And it will create you a file in a path like this:


I have tried this too.It was not happening

From my test, it’s working as expected.
Did you try to set a simple string in sub_folder_name? Something like “Captured
What were the results?
Did you try to call it without defining the sub_folder_name? what was the result ?.”

Here is my turnon code:{
“highlights” : {
“enable” : true,
“requiredHighlights” : [“kill”]
“settings” : {
“gif_as_video”: false,
“max_quota_gb” : 2,
“video” : {
“sub_folder_name” : “Round”,
“fps” :30,
“width” :1920,
“height” : 1080,
“max_kbps” : 100,
“frame_interval”: 30,
“notify_dropped_frames_ratio”: 30,
“max_file_size_bytes” : 10000000,
“include_full_size_video” : false,
“disable_when_sht_not_supported” : false ,
“indication_position”: overwolf.streaming.enums.IndicationPosition.BottomLeftCorner,
“use_app_display_name” : false
here is the location of the videos:

I dont see the round folder here. My plan is create a folder on each round

I have tried without sub folder name. Behavior is same like earlier. I think sub folder setting is not getting applied.

Hi @sureshgoud14,

So you are right. It looks that the sub_folder_name only works if you are using the streaming API and not the reply API… I’m checking if it’s a bug or by design. And I will fix the docs accordingly.


Please update me on this

Hi. It looks like a bug. The sub_folder_name should be supported in both APIs.
I forward it to the R&D for further examination.