[TFT] battle_start and battle_end events stop working

Related Games: Teamfight Tactics

Related app/team name (not a must if you want to keep it private): MetaTFT

Issue Description: Many users are reporting that our win chance feature isn’t working for them. Upon inspection of the Game Event Provider logs, this is because the “battle_start” and “battle_end” events aren’t firing, which we use for timing.

Can you reproduce it (exact steps to reproduce): I was not able to reproduce this myself, although it did break for me at one point several days ago. It started working again 2 days later.

Impact for my app: High - an increasing number of users are reporting this issue.

Do you currently have a workaround? No. According to users even a full restart doesn’t fix

Please reproduce and attach a zip package of your OW client logs
Please mention the time of the event so we can find it easily in the logs

I have attached the logs of 4 users all reporting this issue. The battle_start and battle_end events aren’t working in most of their games

logs2.zip (1.6 MB)
logs.zip (663.1 KB)
logs4.zip (7.5 MB)
logs3.zip (878.5 KB)

Hello @Guthers, thanks for the feedback, we released a fix for the issue a few hours ago :slight_smile:

1 Like

Perfect, thanks very much!

Hi @Jacks

I experienced this issue again in a game - attached are my logs. I believe I am on the most up to date GEP version

OverwolfLogs_2022-09-17_17-41-48.zip (4.0 MB)

Hey @Guthers, thanks.
We’ll look into this and get back to you.

Hi again, I can’t reproduce the issue on my end but If you can give me your name on slack I will send you a debug GEP version that could help us find the issue.