In_game windows are not visible in OpenGL games when launched after the game is open

Issue Description:
All in_game windows are not visible in OpenGL games when the app is launched after the game is already open.

Auto-launching the app and having the app open before opening the game does not have this issue.

Tested on Insights Capture, Outplayed, and my demo app.

Can you reproduce it (exact steps to reproduce):
Either use the demo I provided below or use another app. I tried it on Insights Capture and Outplayed as well. They both have the same behaviour.

  1. open Osu!
  2. launch the app
  3. in_game windows don’t show

Try the steps above with Osu! in compatibility mode ( Options > Renderer > Compatibility mode) to run Osu! in DirectX and the in_game windows will show.

Impact for my app:

Do you currently have a workaround?
No. Only way to get around this issue is to close and reopen the game.

Demo app:

  • download main branch
  • run npm i and npm run build
  • load build folder as unpacked extension

It’s a “known bug”, Overwolf doesnt show on OpenGL rendering.

It happens also on other games like Euro Truck Simulator 2 and American Truck Simulator.

i’ll follow this to see if there is an interesting outcome :slight_smile:

I’ve only started seeing this issue recently, so I don’t know how long this has been “known” for. I’m surprised there isn’t already a discuss thread for this issue if people are running into this problem.

for me is really known, don’t know if is related with the games i support but there never worked.