Me -> inventory weapon update is not working for at least 3 weapons

Issue Description: some weapons are not being received on the weapons update event,
instead, the equipped slot is being sent as empty.
Steps to reproduce:
#pick up one of the following weapons: LSTAR, Charge Rifle, Sentinel.
##receive a wrong event.
###be sad.

Impact for my app: high
Do you currently have a workaround? nope

Thanks @boazrl, We will check it up and let you know.

1 Like


According to my test ( sentinel is received like every other weapon.
Same goes for the L-Star but didn’t catch the 3rd one.

What about the third one? Is this a weapon we would need to develop an event for or is this a bug?


Hey shargaas, the event i was working with and the one with the issue is:
{info: {“info”:{“me”:{“weapons”:"{“weapon0”:“Longbow DMR”,“weapon1”:“P2020”}"}},“feature”:“inventory”}},

unless fixed i might be able to use the in use event as a partial bypass, but for example will never be aware of a situation where lets say
weapon0 = r99
weapon1 = LSTAR

R99 is in use
LSTAR was thrown away. using backpack right-click
since the in use weapon will not be called cause the in use weapon was never changed (still r99)
and my equipped weapons event already showed me a “weapon0: r99” (without weapon1 since those weapons don’t turn up there )
i will not be able to catch the change. and display the information at real-time

if you could somehow make that event show the weapons properly and not only the in-use event it would be really awesome.

also, if you have the names of those 3 weapons already sitting there in front of your eyes in the code - id be glad to have them :smiley:

also also what does mp stand for in mp_weapon_sentinel


I don’t know what it stands for, sorry :stuck_out_tongue:
Though while on the same subject - Charge rifle is {\"inUse\":\"mp_weapon_defender\"}"}}.

Regarding weapon feature, it’s not working as intended currently. We’ll open a bug and fix it soon.
Until then I suggest using the inUse category as a workaround.

the new volt smg weapon suffers from the same bug…
becoming pretty high priority for us, being used in a loved component of our app which is now broken for those 4 weapons…

we will soon celebrate a Bar Mitzva for this bug, prepare the checks.

We chage it to higher priority. We’ll try fixing it in 2-3 weeks.

Hey Eran, any update?

@boazrl Chceking the status and let you know. Thanks.

We’ll release a fix for this issue in about 2 hours

@boazrl we released the fix. Please confirm that it’s working as expected.

1 Like

my GEP is still running on the old 180.0.0, tried updating with the “Developers” version link - still the same…
manual update from about page - same…
guess we will wait for the normal rollout to continue :slight_smile:
I will update the moment I have the events.
Btw… if you know of a force update method, please let me know :smiley:

Try now @boazrl
You should see this version:

Charge Rifle

are all being received, THANK YOU!

now we are only missing the most used weapon of the season… The Volt SMG
Any chance we will see a fix for that weapon as well?

yes, we’ll add it tomorrow

Sure, it’s a quick fix. I’ll take care of it in the morning.

Thanks for the patience! :slight_smile:

If it is possible, please use the name “Volt”
I will pre-insert it as such and it will work right away once the event is added.
Much appreciation and love to all of you

We prefer to keep as close to the game outputs as possible so just FYI it will be named “Volt SMG”.