Issue with loss of game input for user in R6:Siege

I have an issue with the R6:Siege integration where my users are losing the ability to control their game if they dismiss the Overwolf overlay in a specific manner.

This started with the new season update, and is an issue on both DirectX and Vulkan versions.

I can confirm it is not my own app’s coding, as an old version of the app (which worked perfectly before), is showing the same issue in this latest build of the game.

I believe this has something to do with a bug in the OverlayManager where it does OVERLAY_CONTROL_ON even though all Overwolf overlay windows are dismissed.

Here’s a video I made with explanation, which you can cross-reference with the logs.
The issue in question occurs on timestamp 04:17 in the video.
That correlates to 13:08:11 in the logs.

And an .opk you can use to replicate the issue:
test-build-input-loss.opk (112.4 KB) (1.9 MB)

1 Like

@Bl0n Thanks. We will check it and let you know.
(Today we are on a local holiday).

Looks like users can now run set the game to use Raw Input in the Settings -> Controls of the game, and this, with this setting on, the bug reproduces.

We’re looking into both a games list fix and we might also need a client fix (which usually takes longer)

A workaround in the meantime is to set the Raw Input settings to off in the R6 Settings.

1 Like

I understand that the issue is solved in OW v0.157.
Closing the ticket.
If you need to re-open it, please mention me here, and I’ll reopen it.


Although this is resolved during a match, the issue is still present when at the end of a match and returning to the Main Menu. There is no visible mouse cursor (but moving the mouse around does highlight the buttons in the menu).

So although no longer a maximum priority issue, definitely still something to try and resolve in time.

The issue in fixing this is reproducibility. It doesn’t happen every time, just some of the time, with no discernable pattern.